Commit 4900dde0 authored by Jehan's avatar Jehan

gitlab-ci: build with --with-lua=force.

Same as with JS and Python, Lua dependencies are not a build blocker.
It's mostly a packager warning.
parent 0abdbeba
Pipeline #105278 passed with stages
in 24 minutes and 23 seconds
......@@ -149,7 +149,7 @@ gegl-git-autotools:
GIT_STRATEGY: none
script:
- cd _build
- LIBMYPAINT_CFLAGS="-I/usr/include/libmypaint-1.3 -I/usr/include/json-c" LIBMYPAINT_LIBS="-lmypaint-1.3 -ljson-c" PKG_CONFIG_PATH="$INSTALL_PREFIX/lib/pkgconfig" ../autogen.sh --prefix="$INSTALL_PREFIX" $CONFIG_OPTIONS --with-python=force --with-javascript=force
- LIBMYPAINT_CFLAGS="-I/usr/include/libmypaint-1.3 -I/usr/include/json-c" LIBMYPAINT_LIBS="-lmypaint-1.3 -ljson-c" PKG_CONFIG_PATH="$INSTALL_PREFIX/lib/pkgconfig" ../autogen.sh --prefix="$INSTALL_PREFIX" $CONFIG_OPTIONS --with-python=force --with-javascript=force --with-lua=force
- LD_LIBRARY_PATH="$INSTALL_PREFIX/lib:$LD_LIBRARY_PATH" make -j `nproc`
# - LD_LIBRARY_PATH="$INSTALL_PREFIX/lib:$LD_LIBRARY_PATH" make check
artifacts:
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment