Commit 47697d28 authored by Manish Singh's avatar Manish Singh Committed by Manish Singh

Allow overriding from shell environment variables, and prefer any overrid

2005-12-06  Manish Singh  <yosh@gimp.org>

        * autogen.sh: Allow overriding from shell environment variables,
        and prefer any overrid automakes to the default, so long as the
        version is new enough.
parent 5fb29138
2005-12-06 Manish Singh <yosh@gimp.org>
* autogen.sh: Allow overriding from shell environment variables,
and prefer any overrid automakes to the default, so long as the
version is new enough.
2005-12-06 Sven Neumann <sven@gimp.org> 2005-12-06 Sven Neumann <sven@gimp.org>
* autogen.sh: applied a patch provided by Pierre-Paul Lavoie that * autogen.sh: applied a patch provided by Pierre-Paul Lavoie that
......
...@@ -9,11 +9,11 @@ ...@@ -9,11 +9,11 @@
# tools and you shouldn't use this script. Just call ./configure # tools and you shouldn't use this script. Just call ./configure
# directly. # directly.
ACLOCAL=aclocal AUTOCONF=${AUTOCONF-autoconf}
AUTOCONF=autoconf AUTOHEADER=${AUTOHEADER-autoheader}
AUTOHEADER=autoheader AUTOMAKE=${AUTOMAKE-automake-1.9}
AUTOMAKE=automake ACLOCAL=${ACLOCAL-aclocal-1.9}
LIBTOOLIZE=libtoolize LIBTOOLIZE=${LIBTOOLIZE-libtoolize}
PROJECT="GNU Image Manipulation Program" PROJECT="GNU Image Manipulation Program"
TEST_TYPE=-d TEST_TYPE=-d
...@@ -127,15 +127,15 @@ fi ...@@ -127,15 +127,15 @@ fi
echo -n "checking for automake >= $AUTOMAKE_REQUIRED_VERSION ... " echo -n "checking for automake >= $AUTOMAKE_REQUIRED_VERSION ... "
if (automake-1.9 --version) < /dev/null > /dev/null 2>&1; then if ($AUTOMAKE --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=$AUTOMAKE
ACLOCAL=$ACLOCAL
elif (automake-1.9 --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=automake-1.9 AUTOMAKE=automake-1.9
ACLOCAL=aclocal-1.9 ACLOCAL=aclocal-1.9
elif (automake-1.8 --version) < /dev/null > /dev/null 2>&1; then elif (automake-1.8 --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=automake-1.8 AUTOMAKE=automake-1.8
ACLOCAL=aclocal-1.8 ACLOCAL=aclocal-1.8
elif ($AUTOMAKE --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=$AUTOMAKE
ACLOCAL=$ACLOCAL
else else
echo echo
echo " You must have automake $AUTOMAKE_REQUIRED_VERSION or newer installed to compile $PROJECT." echo " You must have automake $AUTOMAKE_REQUIRED_VERSION or newer installed to compile $PROJECT."
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment