Commit 413dc033 authored by Michael Natterer's avatar Michael Natterer 😴

libgimpwidgets: don't call gtk_dialog_set_has_separator()

It's deprecated in GTK+ 2.22. Instead use g_object_set() and add a
comment as reminder to remove that too later.
parent 339deed1
......@@ -120,7 +120,8 @@ gimp_dialog_class_init (GimpDialogClass *klass)
static void
gimp_dialog_init (GimpDialog *dialog)
{
gtk_dialog_set_has_separator (GTK_DIALOG (dialog), FALSE);
/* remove this once we depend on gtk 2.22 (where it defaults to FALSE) */
g_object_set (G_OBJECT (dialog), "has-separator", FALSE, NULL);
g_signal_connect (dialog, "response",
G_CALLBACK (gimp_dialog_response),
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment