Commit 3b5bc9f0 authored by Jehan's avatar Jehan
Browse files

gitlab-ci: don't use mypaint-brushes from Archlinux.

If I get it correctly, archlinux bumped the mypaint-brushes package to
v2, which broke our CI. The v1 and v2 brushes are not the same, and they
are not even compatible (GIMP only supports v1 brushes so far). These
should be different packages, hence the incremented major versionning.
For the archlinux change, see also:
https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/mypaint-brushes&id=dfd032b3aab40a46c751bd47713fb82bf11bd984

Let's just install the brushes ourselves from the correct branch.

With this kind of changes, as well as the weird patches they do when
they rename the pkg-config file of libmypaint, I think we should
consider not rely on this distribution for our CI.
parent 899cf96e
Pipeline #107100 passed with stages
in 22 minutes and 9 seconds
image: archlinux/base:latest
stages:
- mypaint-brushes
- babl
- gegl
- gimp
......@@ -14,6 +15,30 @@ cache:
paths:
- _pacman_cache
.mypaint-brushes-base:
stage: mypaint-brushes
artifacts:
paths:
- "${INSTALL_DIR}"
variables:
GIT_DEPTH: "5"
before_script:
- pacman -Syu --noconfirm --needed --cachedir "${PACMAN_CACHE}"
git
base-devel
- git clone --branch=v1.3.x --depth="${GIT_DEPTH}" https://github.com/mypaint/mypaint-brushes.git _mypaint-brushes
mypaint-brushes-git:
extends: .mypaint-brushes-base
script:
- cd _mypaint-brushes
- ./autogen.sh
- mkdir _build
- cd _build
- ../configure
--prefix="${INSTALL_PREFIX}"
- make install
.babl-base:
stage: babl
artifacts:
......@@ -116,7 +141,7 @@ gegl-git:
variables:
GIT_DEPTH: "5"
before_script:
- export PKG_CONFIG_PATH="${INSTALL_PREFIX}/lib/pkgconfig"
- export PKG_CONFIG_PATH="${INSTALL_PREFIX}/lib/pkgconfig:${INSTALL_PREFIX}/share/pkgconfig"
- export LD_LIBRARY_PATH="${INSTALL_PREFIX}/lib:${LD_LIBRARY_PATH}"
- export XDG_DATA_DIRS="${INSTALL_PREFIX}/share:/usr/local/share:/usr/share"
- pacman -Syu --noconfirm --needed --cachedir "${PACMAN_CACHE}"
......@@ -181,6 +206,7 @@ gegl-git:
build-git-autotools:
extends: .gimp-autotools
dependencies:
- mypaint-brushes-git
- babl-git
- gegl-git
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment