Commit 1778b39f authored by Michael Natterer's avatar Michael Natterer 😴 Committed by Michael Natterer

check for libgnomeui-2.0. Added version requirements (>= 2.10.0) for

2005-08-15  Michael Natterer  <mitch@gimp.org>

	* configure.in: check for libgnomeui-2.0. Added version
	requirements (>= 2.10.0) for libgnomeui and gnome-vfs.

	* plug-ins/uri/Makefile.am
	* plug-ins/uri/uri-backend-gnomevfs.c: if libgnomeui is available,
	call gnome_authentication_manager_init() so the URI plug-in can
	access sites that require authentication.

	(this needs more hacking so packagers can build both versions of
	the uri plug-in at the same time, since they will want to make the
	libgnomeui dependency optional)
parent 16546f0e
2005-08-15 Michael Natterer <mitch@gimp.org>
* configure.in: check for libgnomeui-2.0. Added version
requirements (>= 2.10.0) for libgnomeui and gnome-vfs.
* plug-ins/uri/Makefile.am
* plug-ins/uri/uri-backend-gnomevfs.c: if libgnomeui is available,
call gnome_authentication_manager_init() so the URI plug-in can
access sites that require authentication.
(this needs more hacking so packagers can build both versions of
the uri plug-in at the same time, since they will want to make the
libgnomeui dependency optional)
2005-08-15 Michael Natterer <mitch@gimp.org>
* plug-ins/common/randomize.c
......
......@@ -55,6 +55,8 @@ m4_define([rsvg_required_version], [2.8.0])
m4_define([wmf_required_version], [0.2.8])
m4_define([pygtk_required_version], [1.99.15])
m4_define([poppler_required_version], [0.3.1])
m4_define([gnome_vfs_required_version], [2.10.0])
m4_define([gnomeui_required_version], [2.10.0])
AC_INIT([GIMP], [gimp_version],
[http://bugzilla.gnome.org/enter_bug.cgi?product=GIMP],
......@@ -1187,13 +1189,28 @@ AC_SUBST(LIBPOPPLER)
# Check for gnome-vfs
#####################
PKG_CHECK_MODULES(GNOMEVFS, gnome-vfs-2.0,
PKG_CHECK_MODULES(GNOMEVFS, gnome-vfs-2.0 >= gnome_vfs_required_version,
have_gnomevfs=yes,
AC_MSG_WARN([*** URI plug-in will be built without gnome-vfs support (gnome-vfs-2.0 not found) ***]))
AM_CONDITIONAL(HAVE_GNOMEVFS, test x$have_gnomevfs = xyes)
######################
# Check for libgnomeui
######################
PKG_CHECK_MODULES(GNOMEUI, libgnomeui-2.0 >= gnomeui_required_version,
have_gnomeui=yes,
AC_MSG_WARN([*** URI plug-in will be built without libgnomeui support (libgnomeui-2.0 not found) ***]))
AM_CONDITIONAL(HAVE_GNOMEUI, test x$have_gnomeui = xyes)
if test "x$have_gnomeui" != xyes; then
AC_DEFINE(HAVE_GNOMEUI, 1, "Define to 1 if libgnomeui is available"),
fi
######################
# Check for gimp-print
######################
......
......@@ -20,8 +20,13 @@ libexec_PROGRAMS = uri
if HAVE_GNOMEVFS
backend_sources = uri-backend-gnomevfs.c
if HAVE_GNOMEUI
backend_cflags = $(GNOMEVFS_CFLAGS) $(GNOMEUI_CFLAGS)
backend_libs = $(GNOMEVFS_LIBS) $(GNOMEUI_LIBS)
else
backend_cflags = $(GNOMEVFS_CFLAGS)
backend_libs = $(GNOMEVFS_LIBS)
endif
else
backend_sources = uri-backend-wget.c
endif
......
......@@ -20,6 +20,10 @@
#include <libgnomevfs/gnome-vfs.h>
#ifdef HAVE_GNOMEUI
#include <libgnomeui/gnome-authentication-manager.h>
#endif
#include <libgimp/gimp.h>
#include "libgimp/stdplugins-intl.h"
......@@ -54,6 +58,10 @@ uri_backend_init (GError **error)
return FALSE;
}
#ifdef HAVE_GNOMEUI
gnome_authentication_manager_init ();
#endif
return TRUE;
}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment