Dockerfile 1.01 KB
Newer Older
1
2
3
4
5
6
7
# gimpbuilder-base

FROM debian:testing

ENV PREFIX=/export/output
ENV PATH=$PREFIX/bin:$PATH
ENV PKG_CONFIG_PATH=$PREFIX/lib/pkgconfig:$PKG_CONFIG_PATH
8
ENV APT_GET_OPTIONS="-o APT::Install-Recommends=0 -y"
9
10
11
12

RUN apt-get update

# Installing the build environment
13
RUN apt-get install $APT_GET_OPTIONS build-essential devscripts fakeroot quilt dh-make automake libdistro-info-perl less nano
14
15
16
17
18

# Installing additional dependencies for babl
# none needed

# Installing additional dependencies for GEGL
19
RUN apt-get install $APT_GET_OPTIONS intltool libglib2.0-dev libjson-c-dev libjson-glib-dev libgexiv2-dev libcairo2-dev libpango1.0-dev libjpeg62-turbo-dev libsuitesparse-dev libspiro-dev libopenexr-dev libwebp-dev
20
21

# Installing additional dependencies for GIMP 
22
RUN apt-get install $APT_GET_OPTIONS xsltproc gtk-doc-tools libgtk2.0-dev libtiff5-dev libbz2-dev liblzma-dev librsvg2-dev liblcms2-dev python-cairo-dev python-gtk2-dev glib-networking libaa1-dev libgs-dev libpoppler-glib-dev libmng-dev libwmf-dev libxpm-dev libasound2-dev