Commit 56d21c6a authored by Ed J's avatar Ed J

Release 2.31_06

parent 9082ca8a
Revision history for Perl module Gimp
2.31_06 2016-05-07
Bug fixes:
- force locale as 5.20.0 in de_DE fails on "use 5.006_001"
2.31_05 2016-05-05
Build:
......
......@@ -10,7 +10,7 @@ our (
use subs qw(init end lock unlock);
BEGIN {
$VERSION = '2.31_05'; # going forward: 2.xx, or 2.xx_yy for dev
$VERSION = '2.31_06'; # going forward: 2.xx, or 2.xx_yy for dev
eval {
require XSLoader;
XSLoader::load Gimp $VERSION;
......
......@@ -5,7 +5,7 @@ use strict qw(vars);
our ($VERSION, @EXPORT, @PARAMS, @INXS);
BEGIN {
$VERSION = "2.31_05";
$VERSION = "2.31_06";
# XS code in Gimp.xs... for now
# eval {
# require XSLoader;
......
......@@ -12,7 +12,7 @@ use Gtk2;
sub __ ($) { goto &Gimp::__ }
sub main { goto &Gimp::main; }
our $VERSION = "2.31_05";
our $VERSION = "2.31_06";
our @EXPORT = qw(podregister main add_listener register_temp podregister_temp);
# this is to avoid warnings from importing main etc from Gimp::Fu AND here
......
......@@ -11,7 +11,7 @@ use FindBin qw($RealBin $RealScript);
use File::stat;
our $run_mode;
our $VERSION = "2.31_05";
our $VERSION = "2.31_06";
# manual import
sub __ ($) { goto &Gimp::__ }
......
......@@ -5,7 +5,7 @@ use warnings;
use vars qw($VERSION @ISA);
BEGIN {
$VERSION = "2.31_05";
$VERSION = "2.31_06";
require XSLoader;
XSLoader::load Gimp::Lib $VERSION;
warn "$$-Loading ".__PACKAGE__ if $Gimp::verbose >= 2;
......
......@@ -33,7 +33,7 @@ use IO::Socket;
use Carp 'croak';
use Fcntl qw(F_SETFD);
$VERSION = "2.31_05";
$VERSION = "2.31_06";
bootstrap Gimp::Net $VERSION;
my $PROTOCOL_VERSION = 5; # protocol version
......
......@@ -10,7 +10,7 @@ use base 'Exporter';
use Pod::Simple::SimpleTree;
our @EXPORT = qw(fixup_args make_arg_line);
our $VERSION = "2.31_05";
our $VERSION = "2.31_06";
warn "$$-Loading ".__PACKAGE__ if $Gimp::verbose >= 2;
......
......@@ -15,7 +15,7 @@ use warnings;
our (@ISA, $VERSION);
BEGIN {
no locale;
$VERSION = "2.31_05";
$VERSION = "2.31_06";
eval {
require XSLoader;
XSLoader::load Gimp::UI $VERSION;
......
......@@ -14,7 +14,7 @@ our @EXPORT_OK = qw(
sub __ ($); # declare - defined in Gimp
our $VERSION = "2.31_05";
our $VERSION = "2.31_06";
sub get_state() {
[
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment