Commit abb3f38d authored by Sven Neumann's avatar Sven Neumann

require automake >= 1.9.6 and libtool >= 1.5

parent 92065567
The git version of GEGL is known to work with the following autotools:
- GNU autoconf 2.53
- GNU automake 1.7.5
- GNU libtool 1.4.3
- GNU autoconf 2.54
- GNU automake 1.9.6
- GNU libtool 1.5
Other versions of these tools probably work. Probably the tools that
work for current versions of glib will work for gegl as well.
Newer versions of these tools will probably work.
To compile a git version of GEGL on your system, you will need to take several
steps to setup the tree for compilation. You can do all these steps at once by
running:
To compile a git version of GEGL on your system, you will need to take
several steps to setup the tree for compilation. You can do all these
steps at once by running:
gegl> ./autogen.sh
Basically this does the following for you (but see autogen.sh for exactly what
is happening):
Basically this does the following for you (but see autogen.sh for
exactly what is happening):
gegl> aclocal
gegl> automake
......
......@@ -16,11 +16,10 @@ AUTOMAKE=${AUTOMAKE-automake-1.9}
LIBTOOLIZE=${LIBTOOLIZE-libtoolize}
AUTOCONF_REQUIRED_VERSION=2.54
AUTOMAKE_REQUIRED_VERSION=1.7
AUTOMAKE_REQUIRED_VERSION=1.9.6
GLIB_REQUIRED_VERSION=2.8.0
INTLTOOL_REQUIRED_VERSION=0.31
LIBTOOL_REQUIRED_VERSION=1.4
LIBTOOL_WIN32=1.5
LIBTOOL_REQUIRED_VERSION=1.5
PROJECT="GEGL"
......@@ -82,16 +81,6 @@ echo
DIE=0
OS=`uname -s`
case $OS in
*YGWIN* | *INGW*)
echo "Looks like Win32, you will need libtool $LIBTOOL_WIN32 or newer."
echo
LIBTOOL_REQUIRED_VERSION=$LIBTOOL_WIN32
;;
esac
echo -n "checking for libtool >= $LIBTOOL_REQUIRED_VERSION ... "
if ($LIBTOOLIZE --version) < /dev/null > /dev/null 2>&1; then
LIBTOOLIZE=$LIBTOOLIZE
......@@ -160,19 +149,15 @@ echo -n "checking for automake >= $AUTOMAKE_REQUIRED_VERSION ... "
if ($AUTOMAKE --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=$AUTOMAKE
ACLOCAL=$ACLOCAL
elif (automake-1.11 --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=automake-1.11
ACLOCAL=aclocal-1.11
elif (automake-1.10 --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=automake-1.10
ACLOCAL=aclocal-1.10
elif (automake-1.9 --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=automake-1.9
ACLOCAL=aclocal-1.9
elif (automake-1.8 --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=automake-1.8
ACLOCAL=aclocal-1.8
AUTOMAKE_REQUIRED_VERSION=1.8.3
elif (automake-1.7 --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=automake-1.7
ACLOCAL=aclocal-1.7
else
echo
echo " You must have automake $AUTOMAKE_REQUIRED_VERSION or newer installed to compile $PROJECT."
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment