Commit 70601484 authored by Kevin Cozens's avatar Kevin Cozens

Check for Lua 5.1.0 or newer.

* configure.ac: Check for Lua 5.1.0 or newer.

svn path=/trunk/; revision=2049
parent 157b63d8
2008-02-18 Kevin Cozens <kcozens@cvs.gnome.org>
* configure.ac: Check for Lua 5.1.0 or newer.
2008-02-18 Sven Neumann <sven@gimp.org>
* configure.ac: use G_DISABLE_DEPRECATED for GLib version < 2.15.
......
......@@ -41,6 +41,7 @@ m4_define([gimp_full_name], [Generic Graphical Library])
m4_define([babl_required_version], [0.0.14])
m4_define([glib_required_version], [2.14.1])
m4_define([gtk_required_version], [2.8.6])
m4_define([lua_required_version], [5.1.0])
m4_define([cairo_required_version], [0.0.0])
m4_define([pango_required_version], [0.0.0])
m4_define([pangocairo_required_version], [0.0.0])
......@@ -112,6 +113,9 @@ GTK_REQUIRED_VERSION=gtk_required_version
AC_SUBST(GLIB_REQUIRED_VERSION)
AC_SUBST(GTK_REQUIRED_VERSION)
LUA_REQUIRED_VERSION=lua_required_version
AC_SUBST(LUA_REQUIRED_VERSION)
PACKAGE_NAME=gegl
AC_SUBST(PACKAGE_NAME)
......@@ -414,13 +418,9 @@ AC_CHECK_PROGS(PERL, perl5 perl)
# Check for Lua
###############
PKG_CHECK_MODULES(LUA, lua,
PKG_CHECK_MODULES(HAVE_LUA, lua >= $LUA_REQUIRED_VERSION,
have_lua="yes",
[PKG_CHECK_MODULES(LUA, lua5.1,
have_lua="yes",
[PKG_CHECK_MODULES(LUA, lua50,
have_lua="yes",
have_lua="no (usable lua not found)")])])
have_lua="no (usable lua not found)")
AM_CONDITIONAL(HAVE_LUA, test "x$have_lua" = "xyes")
AC_SUBST(LUA_CFLAGS)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment