Commit 157b63d8 authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

use G_DISABLE_DEPRECATED for GLib version < 2.15.

2008-02-18  Sven Neumann  <sven@gimp.org>

	* configure.ac: use G_DISABLE_DEPRECATED for GLib version < 
2.15.


svn path=/trunk/; revision=2048
parent dacb9cff
2008-02-18 Sven Neumann <sven@gimp.org>
* configure.ac: use G_DISABLE_DEPRECATED for GLib version < 2.15.
2008-02-18 Sven Neumann <sven@gimp.org>
* gegl/gegl-init.c: never include gi18n.h from a library, use
......
......@@ -384,15 +384,15 @@ LIBS=$gegl_save_LIBS
# Disable deprecated APIs
#########################
AC_MSG_CHECKING([if GLib is version 2.11.0 or newer])
if $PKG_CONFIG --atleast-version=2.11.0 glib-2.0; then
have_glib_2_11=yes
AC_MSG_CHECKING([if GLib is version 2.15.0 or newer])
if $PKG_CONFIG --atleast-version=2.15.0 glib-2.0; then
have_glib_2_15=yes
else
have_glib_2_11=no
have_glib_2_15=no
fi
AC_MSG_RESULT($have_glib_2_11)
AC_MSG_RESULT($have_glib_2_15)
if test "x$have_glib_2_11" != "xyes"; then
if test "x$have_glib_2_15" != "xyes"; then
CPPFLAGS="${CPPFLAGS} -DG_DISABLE_DEPRECATED"
fi
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment