Commit cfeb7cb6 authored by Sébastien Wilmet's avatar Sébastien Wilmet

build: add Tepl dependency, second try

First step to be able to use the Tepl library:
https://wiki.gnome.org/Projects/Tepl

as part of this project:
https://wiki.gnome.org/Apps/Gedit/ReusableCode

tepl_req and tepl_dep follow gtksourceview_req/dep: wherever the
gtksourceview one is present, add a line for tepl too.

This was reverted in commit 38f10366
because gnome-build-meta was not updated beforehand. I thought that it
was fine to update gnome-build-meta afterwards, but nowadays
gnome-build-meta should be able to build everything at all time (which
is perfectly understandable).

#229
gnome-build-meta!440
parent d7663852
Pipeline #129700 passed with stage
in 6 minutes and 36 seconds
......@@ -13,6 +13,7 @@ gedit_doc_deps = [
gio_dep,
gtk_dep,
gtksourceview_dep,
tepl_dep,
libpeas_dep,
libpeas_gtk_dep,
libxml_dep,
......
......@@ -129,6 +129,7 @@ libgedit_deps = [
gio_dep,
gtk_dep,
gtksourceview_dep,
tepl_dep,
introspection_dep,
libpeas_dep,
libpeas_gtk_dep,
......
......@@ -63,6 +63,7 @@ libgd_sp = subproject(
glib_req = '>= 2.44.0'
gtk_req = '>= 3.22.0'
gtksourceview_req = '>= 4.0.2'
tepl_req = '>= 4.3'
libpeas_req = '>= 1.14.1'
libxml_req = '>= 2.5.0'
libsoup_req = '>= 2.60.0'
......@@ -79,6 +80,7 @@ gio_dep = dependency('gio-2.0', version: glib_req)
gdk_dep = dependency('gdk-3.0', version: gtk_req)
gtk_dep = dependency('gtk+-3.0', version: gtk_req)
gtksourceview_dep = dependency('gtksourceview-4', version: gtksourceview_req)
tepl_dep = dependency('tepl-4', version: tepl_req)
libpeas_dep = dependency('libpeas-1.0', version: libpeas_req)
libpeas_gtk_dep = dependency('libpeas-gtk-1.0', version: libpeas_req)
libxml_dep = dependency('libxml-2.0', version: libxml_req)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment