Commit 8ad1520a authored by Paolo Maggi's avatar Paolo Maggi Committed by Paolo Maggi

requires gtksourceview 0.9, sets version to 2.5.90

2004-02-24  Paolo Maggi  <paolo.maggi@polito.it>

	* configure.in: requires gtksourceview 0.9, sets version
	to 2.5.90

	* README: bump version to 2.5.90

	* NEWS: updated
parent b6bc9093
2004-02-24 Paolo Maggi <paolo.maggi@polito.it>
* configure.in: requires gtksourceview 0.9, sets version
to 2.5.90
* README: bump version to 2.5.90
* NEWS: updated
2004-02-23 Padraig O'Briain <padraig.obriain@sun.com>
* gedit/dialogs/gedit-close-confirmation-dialog.c
......@@ -6,7 +15,7 @@
2004-02-21 Christian Rose <menthos@menthos.com>
* configure.in: Added "en_CA" to ALL_LINGUAS.
* configure.in: Added "en_CA" to ALL_LINGUAS.
2004-02-15 Tomasz Kłoczko <kloczek@pld.org.pl>
......
Sigh... I didn't update the NEWS since 2.4.1
=============
gedit 2.5.90"
=============
New features
============
- added a --enable-deprecations flag to configure.in
to switch on the DISABLE_DEPRECATED cflags (Mark McLoughlin)
Fixes
=====
- Bug #133178 (Underquoted definitions in acinclude.m4) (Alexander Winston)
- Removed unused gconf key
schemas/apps/gedit-2/preferences/editor/save/save_encoding (Paolo Maggi)
- Removed AC_SUBST(CFLAGS), AC_SUBST(CPPFLAGS) and AC_SUBST(LDFLAGS)
from configure.in (Tomasz Kłoczko)
- Bug #135000 ("Save the changes to document before closing"
dialog should have Accessible Role "ALERT") (Padraig O'Briain)
- Uses the new file chooser in the shell_output plugin (Paolo Borelli)
- Disables the menu items when the gedit state is not NORMAL (Paolo M.)
- Bug #133851 (Saves the file on pressing ESC from the
"Save As" dialog) (Paolo B.)
- Don't highlight single column lists (Jeroen Zwartepoorte)
- Uses latest libegg recent-files code (Paolo M.)
- Bug #133604 (The name of filters are not marked for translation) (Paolo M.)
- Bug #133269 (check box check or uncheck is not having any bearing) (Paolo M.)
- Bug #133481 (check box selection is not habing any bearing) (Paolo M.)
- Fixed a lot of bugs in the preferences dialog (Paolo B. and Paolo M.)
- Fixed a lot of bugs in the Open/Save As dialog (Paolo M.)
New and updated translations
============================
- Adam Weinberger (en_CA)
- Alastair McKinstry (ga)
- Åsmund Skjæveland (nn)
- Chanchai Junlouchai (th)
- Changwoo Ryu (ko)
- Christian Neumair (de)
- Christian Rose (sv)
- Christophe Merlet (RedFox) (fr)
- Duarte Loreto (pt)
- GNOME PL Team (pl)
- Hasbullah Bin Pit (ms)
- Jarkko Ranta (fi)
- Joao Emanuel (pt_BR)
- John C Barstow (mi)
- Kjartan Maraas (no)
- Kostas Papadimas (el)
- Laurent Dhima (sq)
- Miloslav Trmac (cs)
- Mətin Əmirov (az)
- Ole Laursen (da)
- Pablo G. del Campo (es)
- Reinout van Schouwen (nl)
- Sanlig Badral (mn)
- Takeshi AIHANA (ja)
- Данило Шеган (sr)
=============================
gedit 2.5.[0123] - "I'm lazy"
......
General Information
===================
This is version 2.5.3 of gedit. gedit is a small and lightweight UTF-8 text
This is version 2.5.90 of gedit. gedit is a small and lightweight UTF-8 text
editor for the GNOME environment.
Designed for the X Window System, it uses the GTK+ 2.2 and GNOME 2.4 libraries.
......@@ -60,12 +60,12 @@ Information about gedit mailing lists can be found at
Installation
============
gedit requires GTK+-2.3.x, GtkSourceView 0.7.0 and GNOME 2.5.x libraries.
gedit requires GTK+-2.3.x, GtkSourceView 0.9.0 and GNOME 2.5.x libraries.
Simple install procedure:
% gzip -cd gedit-2.5.3.tar.gz | tar xvf - # unpack the sources
% cd gedit-2.5.3 # change to the toplevel directory
% gzip -cd gedit-2.5.90.tar.gz | tar xvf - # unpack the sources
% cd gedit-2.5.90 # change to the toplevel directory
% ./configure # run the `configure' script
% make # build gedit
[ Become root if necessary ]
......
......@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_PREREQ(2.52)
AC_INIT(gedit, 2.5.3, http://bugzilla.gnome.org/enter_bug.cgi?product=gedit)
AC_INIT(gedit, 2.5.90, http://bugzilla.gnome.org/enter_bug.cgi?product=gedit)
AC_CONFIG_SRCDIR(gedit/gedit2.c)
AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
......@@ -67,7 +67,7 @@ dnl
dnl Start of pkg-config checks
dnl
PKG_CHECK_MODULES(GEDIT, libgnomeui-2.0 >= 2.5.0 libglade-2.0 >= 2.0.0
eel-2.0 >= 2.5.0 gtksourceview-1.0 >= 0.7.0
eel-2.0 >= 2.5.0 gtksourceview-1.0 >= 0.9.0
libgnomeprintui-2.2 >= 2.5.0)
GEDIT_LIBS="${GEDIT_LIBS}"
AC_SUBST(GEDIT_LIBS)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment