Bump libpeas version and use python3 loader

parent f29420cd
......@@ -328,8 +328,8 @@ PKG_CHECK_MODULES(GEDIT, [
gio-2.0 >= 2.35.4
gtk+-3.0 >= 3.6.0
gtksourceview-3.0 >= 3.0.0
libpeas-1.0 >= 0.7.3
libpeas-gtk-1.0 >= 1.1.0
libpeas-1.0 >= 1.7.0
libpeas-gtk-1.0 >= 1.7.0
gsettings-desktop-schemas
])
......
......@@ -66,7 +66,7 @@ gedit_plugins_engine_init (GeditPluginsEngine *engine)
GEDIT_TYPE_PLUGINS_ENGINE,
GeditPluginsEnginePrivate);
peas_engine_enable_loader (PEAS_ENGINE (engine), "python");
peas_engine_enable_loader (PEAS_ENGINE (engine), "python3");
engine->priv->plugin_settings = g_settings_new ("org.gnome.gedit.plugins");
......
[Plugin]
Loader=python
Loader=python3
Module=externaltools
IAge=3
_Name=External Tools
......
[Plugin]
Loader=python
Loader=python3
Module=pythonconsole
IAge=3
_Name=Python Console
......
[Plugin]
Loader=python
Loader=python3
Module=quickopen
IAge=3
_Name=Quick Open
......
[Plugin]
Loader=python
Loader=python3
Module=snippets
IAge=3
_Name=Snippets
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment