Commit 170d97c4 authored by Jason Leach's avatar Jason Leach Committed by Jacob Leach

Updated requirements to match latest from GNOME 1.4 release.

2001-04-09  Jason Leach  <jasonleach@usa.net>

	* configure.in: Updated requirements to match latest from GNOME
	1.4 release.

	* NEWS: Updated.
parent 2a1226d4
2001-04-09 Jason Leach <jasonleach@usa.net>
* configure.in: Updated requirements to match latest from GNOME
1.4 release.
* NEWS: Updated.
2001-03-31 Paolo Maggi <maggi@athena.polito.it>
* TODO: updated
* TODO: Updated.
2001-03-30 Yukihiro Nakai <nakai@gnome.gr.jp>
......@@ -20,7 +27,7 @@
2001-03-18 Chema Celorio <chema@celorio.com>
* configure.in (ALL_LINGUAS): typo
* configure.in: typo fix.
* NEWS: update for 0.9.6
......@@ -60,7 +67,7 @@
2000-12-26 Pablo Saratxaga <pablo@mandrakesoft.com>
* configure.in,po/az.po: Added Azeri language
* configure.in, po/az.po: Added Azeri language
* gedit.desktop: converted to UTF-8
2000-11-30 Martin Norbck <d95mback@dtek.chalmers.se>
......
gedit 0.9.7 (April ??, 2001)
Requirements updated
* gedit has been updated to require the latest stable versions
of software from the GNOME 1.4 release. This means you will
need the following for gedit:
** libglade 0.16
** gnome-libs 1.2.13
** gnome-print 0.28
** gnome-vfs 1.0
** gtk+ 1.2.9
Updates
* Updated Norwegian, Swedish, Finnish, German, Spanish translations.
Bug Fixes
* Small bug fixes and code cleanups. (Jason, Paolo)
Enjoy.
----------------------------------------------------------------------
gedit 0.9.6 a.k.a "Every cowboy sings his sad, sad song"
In this release :
......@@ -16,7 +41,7 @@ http://gedit.sourceforge.net
Enojy
---------------------------------
----------------------------------------------------------------------
gedit 0.9.5 a.k.a "CAN YOU FEEL THE LOVE ?" has been released.
[I need to go to bed so this is going to be a short annoucement]
......@@ -33,7 +58,7 @@ http://gedit.sourceforge.net
enjoy.
------------------------
----------------------------------------------------------------------
gedit 0.9.4 (Nov 24, 2000)
gedit 0.9.4, codename "Bruta ciega sordomuda torpe traste testaruda"
......@@ -103,7 +128,7 @@ Changes :
regards,
Chema
---------------------------------------------------
----------------------------------------------------------------------
gedit 0.9.0 (Jul 09, 2000)
gedit is a light text editor for the Gnome desktop.
......
......@@ -52,9 +52,9 @@ AM_GNOME_GETTEXT
dnl ******************************
dnl gtk+ checking
dnl ******************************
AM_PATH_GTK(1.2.7,,
AM_PATH_GTK(1.2.9,,
AC_MSG_ERROR([
*** GTK+ 1.2.7 or better is required. The latest version of GTK+
*** GTK+ 1.2.9 or better is required. The latest version of GTK+
*** is always available from ftp://ftp.gtk.org/.]),
)
......@@ -62,14 +62,14 @@ AM_PATH_GTK(1.2.7,,
dnl ******************************
dnl GnomePrint checking
dnl ******************************
AC_MSG_CHECKING(for GnomePrint libraries >= 0.25)
AC_MSG_CHECKING(for GnomePrint libraries >= 0.28)
if gnome-config --libs print > /dev/null 2>&1; then
vers=`gnome-config --modversion print | sed -e "s/gnome-print-//" | \
awk 'BEGIN { FS = "."; } { print $1 * 1000 + $2;}'`
if test "$vers" -ge 25; then
if test "$vers" -ge 28; then
AC_MSG_RESULT(found)
else
AC_MSG_ERROR(You need at least GNOME print 0.25 for this version of gedit)
AC_MSG_ERROR(You need at least GNOME print 0.28 for this version of gedit)
fi
else
AC_MSG_ERROR(Did not find GnomePrint installed)
......@@ -79,13 +79,13 @@ fi
dnl ******************************
dnl LibGlade checking
dnl ******************************
AC_MSG_CHECKING(for Glade libraries >= 0.11)
AC_MSG_CHECKING(for Glade libraries >= 0.16)
if gnome-config --libs libglade > /dev/null 2>&1; then
vers=`gnome-config --modversion libglade | awk 'BEGIN { FS = "."; } { print $1 * 1000 + $2;}'`
if test "$vers" -ge 11; then
if test "$vers" -ge 16; then
AC_MSG_RESULT(found)
else
AC_MSG_ERROR(You need at least libglade 0.11 for this version of gedit)
AC_MSG_ERROR(You need at least libglade 0.16 for this version of gedit)
fi
else
AC_MSG_ERROR(Did not find libGlade installed)
......@@ -95,13 +95,13 @@ fi
dnl ******************************
dnl gnome-libs checking
dnl ******************************
AC_MSG_CHECKING(for gnome-libs >= 1.0.55)
AC_MSG_CHECKING(for gnome-libs >= 1.2.13)
if gnome-config --version > /dev/null 2>&1; then
vers=`gnome-config --version | awk 'BEGIN { FS = "."; } { printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
if test "$vers" -ge 55; then
if test "$vers" -ge 2013; then
AC_MSG_RESULT(found)
else
AC_MSG_ERROR(You need at least gnome-libs 1.0.55 for this version of gedit)
AC_MSG_ERROR(You need at least gnome-libs 1.2.13 for this version of gedit)
fi
else
AC_MSG_ERROR(Did not find gnome-libs installed)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment