Commit 742aca2b authored by Michael Gratton's avatar Michael Gratton 🤞 Committed by Michael Gratton

Add build dependencies for Folks

Flatpak manifest updates courtesy of gnome-contacts.
parent d93e5fe8
......@@ -17,18 +17,21 @@ variables:
# Fedora packages
FEDORA_DEPS: vala
meson desktop-file-utils libcanberra-devel libgee-devel
glib2-devel gmime-devel gtk3-devel libnotify-devel sqlite-devel
webkitgtk4-devel libsecret-devel libxml2-devel vala-tools
gcr-devel enchant2-devel libunwind-devel iso-codes-devel
gnome-online-accounts-devel itstool json-glib-devel
meson desktop-file-utils libcanberra-devel
folks-devel libgee-devel glib2-devel gmime-devel
gtk3-devel libnotify-devel sqlite-devel
webkitgtk4-devel libsecret-devel libxml2-devel
vala-tools gcr-devel enchant2-devel libunwind-devel
iso-codes-devel gnome-online-accounts-devel itstool
json-glib-devel
FEDORA_TEST_DEPS: Xvfb tar xz
# Ubuntu packages
UBUNTU_DEPS: valac build-essential
meson desktop-file-utils libcanberra-dev
libgee-0.8-dev libglib2.0-dev libgmime-2.6-dev libgtk-3-dev
libsecret-1-dev libxml2-dev libnotify-dev libsqlite3-dev
libfolks-dev libgee-0.8-dev libglib2.0-dev
libgmime-2.6-dev libgtk-3-dev libsecret-1-dev
libxml2-dev libnotify-dev libsqlite3-dev
libwebkit2gtk-4.0-dev libgcr-3-dev libenchant-dev
libunwind-dev iso-codes libgoa-1.0-dev itstool gettext
libmessaging-menu-dev libunity-dev libjson-glib-dev
......
......@@ -41,9 +41,9 @@ Installing dependencies on Fedora
Fedora 25 and later ships with the correct versions of the required
libraries. Install them by running this command:
sudo yum install vala meson \
desktop-file-utils iso-codes-devel libcanberra-devel libgee-devel \
glib2-devel gmime-devel gtk3-devel libnotify-devel sqlite-devel \
sudo yum install vala meson desktop-file-utils iso-codes-devel \
libcanberra-devel folks-devel libgee-devel glib2-devel \
gmime-devel gtk3-devel libnotify-devel sqlite-devel \
webkitgtk4-devel libsecret-devel libxml2-devel vala-tools \
gcr-devel enchant2-devel libunwind-devel json-glib-devel \
gnome-online-accounts-devel itstool
......@@ -62,12 +62,12 @@ required libraries.
Install them by running this command:
sudo apt-get install valac \
meson desktop-file-utils iso-codes libcanberra-dev \
libgee-0.8-dev libglib2.0-dev libgmime-2.6-dev libgtk-3-dev \
libsecret-1-dev libxml2-dev libnotify-dev libsqlite3-dev \
libwebkit2gtk-4.0-dev libgcr-3-dev libenchant-dev \
libunwind-dev libgoa-1.0-dev libjson-glib-dev itstool gettext
sudo apt-get install valac meson desktop-file-utils iso-codes \
libcanberra-dev libfolks-dev libgee-0.8-dev libglib2.0-dev \
libgmime-2.6-dev libgtk-3-dev libsecret-1-dev libxml2-dev \
libnotify-dev libsqlite3-dev libwebkit2gtk-4.0-dev \
libgcr-3-dev libenchant-dev libunwind-dev libgoa-1.0-dev \
libjson-glib-dev itstool gettext
And for Ubuntu Unity integration:
......
......@@ -54,6 +54,7 @@ webkit2gtk = dependency('webkit2gtk-4.0', version: '>=' + target_webkit)
# Secondary deps - keep sorted alphabetically
enchant = dependency('enchant-2', version: '>=2.1', required: false) # see below
folks = dependency('folks', version: '>=0.11')
gck = dependency('gck-1')
gcr = dependency('gcr-3', version: '>= 3.10.1')
gdk = dependency('gdk-3.0', version: '>=' + target_gtk)
......
......@@ -74,16 +74,6 @@
}
]
},
{
"name": "gmime",
"sources": [
{
"type": "git",
"url": "https://github.com/jstedfast/gmime.git",
"branch": "gmime-2-6"
}
]
},
{
"name": "gnome-online-accounts",
"config-opts": [
......@@ -105,6 +95,87 @@
}
]
},
{
"name": "libical",
"cleanup": [
"/lib/cmake"
],
"buildsystem": "cmake-ninja",
"config-opts": [
"-DCMAKE_BUILD_TYPE=Release",
"-DCMAKE_INSTALL_LIBDIR=lib",
"-DBUILD_SHARED_LIBS:BOOL=ON"
],
"sources": [
{
"type": "archive",
"url": "https://github.com/libical/libical/releases/download/v2.0.0/libical-2.0.0.tar.gz",
"sha256": "654c11f759c19237be39f6ad401d917e5a05f36f1736385ed958e60cf21456da"
}
]
},
{
"name": "evolution-data-server",
"cleanup": [
"/lib/cmake",
"/lib/evolution-data-server/*-backends",
"/libexec",
"/share/dbus-1/services"
],
"config-opts": [
"-DCMAKE_BUILD_TYPE=Release",
"-DENABLE_GTK=ON",
"-DENABLE_GOA=ON",
"-DENABLE_UOA=OFF",
"-DENABLE_GOOGLE_AUTH=OFF",
"-DENABLE_GOOGLE=OFF",
"-DENABLE_WITH_PHONENUMBER=OFF",
"-DENABLE_VALA_BINDINGS=ON",
"-DENABLE_WEATHER=OFF",
"-DWITH_OPENLDAP=OFF",
"-DWITH_LIBDB=OFF",
"-DENABLE_INTROSPECTION=ON",
"-DENABLE_INSTALLED_TESTS=OFF",
"-DENABLE_GTK_DOC=OFF",
"-DENABLE_EXAMPLES=OFF"
],
"buildsystem": "cmake-ninja",
"sources": [
{
"type": "git",
"url": "https://gitlab.gnome.org/GNOME/evolution-data-server.git"
}
]
},
{
"name": "folks",
"cleanup": [
"/bin",
"/share/GConf"
],
"config-opts": [
"--disable-telepathy-backend",
"--disable-inspect-tool",
"--disable-import-tool",
"--disable-fatal-warnings"
],
"sources": [
{
"type": "git",
"url": "https://gitlab.gnome.org/GNOME/folks.git"
}
]
},
{
"name": "gmime",
"sources": [
{
"type": "git",
"url": "https://github.com/jstedfast/gmime.git",
"branch": "gmime-2-6"
}
]
},
{
"name": "libunwind",
"sources": [
......@@ -121,9 +192,8 @@
"builddir": true,
"sources": [
{
"type": "git",
"url": "https://gitlab.gnome.org/GNOME/geary.git",
"branch": "master"
"type": "dir",
"path": "."
}
]
}
......
......@@ -110,6 +110,7 @@ geary_client_sources = [
geary_client_dependencies = [
libmath,
enchant,
folks,
gck,
gcr,
gee,
......
......@@ -73,6 +73,7 @@ geary_bin_sources += [
geary_resources # Included here so they show up in the executable.
]
geary_bin_dependencies = [
folks,
gdk,
geary_client_dep,
geary_engine_dep,
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment