Commit 27b8450d authored by Eric Gregory's avatar Eric Gregory

Closes #4167 Updated to GMime 2.6

parent d7929a7e
......@@ -222,13 +222,13 @@ pkg_check_modules(DEPS REQUIRED
unique-3.0>=3.0.0
sqlite3>=3.7.4
sqlheavy-0.2>=0.2.0
gmime-2.4>=2.4.14
gmime-2.6>=2.6.0
gnome-keyring-1>=2.32.0
webkitgtk-3.0>=1.4.3
)
set(ENGINE_PACKAGES
glib-2.0 gee-1.0 gio-2.0 sqlheavy-0.2 gmime-2.4 unique-3.0 posix
glib-2.0 gee-1.0 gio-2.0 sqlheavy-0.2 gmime-2.6 unique-3.0 posix
)
set(CLIENT_PACKAGES
......
......@@ -2,21 +2,21 @@
# which are not default in a standard Vala installation.
GMIME_FILES := \
gmime-2.4/gmime-2.4.defines \
gmime-2.4/gmime-2.4.files \
gmime-2.4/gmime-2.4.metadata \
gmime-2.4/gmime-2.4.namespace \
gmime-2.4/gmime-2.4-custom.vala
gmime-2.6/gmime-2.6.defines \
gmime-2.6/gmime-2.6.files \
gmime-2.6/gmime-2.6.metadata \
gmime-2.6/gmime-2.6.namespace \
gmime-2.6/gmime-2.6-custom.vala
all: gmime-2.4.vapi
all: gmime-2.6.vapi
.PHONY: clean
clean:
rm gmime-2.4.vapi gmime-2.4/gmime-2.4.gi
rm gmime-2.6.vapi gmime-2.6/gmime-2.6.gi
gmime-2.4/gmime-2.4.gi: $(GMIME_FILES)
vala-gen-introspect gmime-2.4 gmime-2.4
gmime-2.6/gmime-2.6.gi: $(GMIME_FILES)
vala-gen-introspect gmime-2.6 gmime-2.6
gmime-2.4.vapi: gmime-2.4/gmime-2.4.gi
vapigen --pkg=glib-2.0 --pkg=gio-2.0 --library gmime-2.4 gmime-2.4/gmime-2.4.gi gmime-2.4/gmime-2.4-custom.vala
gmime-2.6.vapi: gmime-2.6/gmime-2.6.gi
vapigen --pkg=glib-2.0 --pkg=gio-2.0 --library gmime-2.6 gmime-2.6/gmime-2.6.gi gmime-2.6/gmime-2.6-custom.vala
include/gmime-2.4/
lib/libgmime-2.4.so
This diff is collapsed.
include/gmime-2.6/
lib/libgmime-2.6.so
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment