Components.WebView: Fix CI failure building with WebKitGTK >= 2.31

The `webkit_settings_set_enable_plugins` method has been deprecated in
2.31, and calling it emits a warning which trips up the test suite.

Cherry picked from !624 commit 28921890
3 jobs for mjog/webkit_plugin_warning-3_38 in 9 minutes and 58 seconds (queued for 1 second)
latest