Commit cfc472cf authored by Jim Nelson's avatar Jim Nelson

Build with WebKitGTK 2.2.0: Closes #7023

Geary will autodetect which version of the library is installed
and select the appropriate .metadata file to use for bindings.
Still backwards-compatible with Geary 1.10 to 2.0.
parent 2401e005
......@@ -52,6 +52,7 @@ endif ()
find_package(PkgConfig)
pkg_check_modules(LIBUNITY QUIET unity>=5.12.0)
pkg_check_modules(LIBMESSAGINGMENU QUIET messaging-menu>=12.10.2)
pkg_check_modules(WEBKITGTK22X QUIET webkitgtk-3.0>=2.2.0)
# intl
include(Gettext)
......
DOM* parent="WebKit.DOM" name="DOM(.+)"
DOMEventTarget.add_event_listener skip=false
DOMEventTarget.add_event_listener.handler closure=-1
DOMEventTarget.add_event_listener.user_data closure=-1
DOMEventTarget.remove_event_listener skip=false
WebView.entering_fullscreen#signal name="entering_fullscreen_signal"
WebView.leaving_fullscreen#signal name="leaving_fullscreen_signal"
WebView.move_cursor#virtual_method name="leaving_fullscreen_method"
WebSettings.enable_default_context_menu#property deprecated=false
......@@ -435,6 +435,29 @@ else ()
message(STATUS "Unity launcher support: OFF")
endif ()
if (WEBKITGTK22X_FOUND)
message(STATUS "Targeting WebKitGTK 2.2.x")
SET(EXTRA_CLIENT_PKG_CONFIG
${EXTRA_CLIENT_PKG_CONFIG}
webkitgtk-3.0>=2.2.0
)
SET(WEBKITGTK_METADATA_DIR
webkitgtk-2.2
)
else ()
message(STATUS "Targeting WebKitGTK 1.10.0 to 2.0.4")
SET(EXTRA_CLIENT_PKG_CONFIG
${EXTRA_CLIENT_PKG_CONFIG}
webkitgtk-3.0>=1.10.0
webkitgtk-3.0<=2.0.4
)
SET(WEBKITGTK_METADATA_DIR
webkitgtk-2.0
)
endif ()
if (NO_FATAL_WARNINGS)
message(STATUS "Vala fatal warnings: OFF")
else ()
......@@ -460,8 +483,6 @@ pkg_check_modules(DEPS REQUIRED
sqlite3>=3.7.4
gmime-2.6>=2.6.0
libsecret-1>=0.11
webkitgtk-3.0>=1.10.0
webkitgtk-3.0<=2.0.4
libxml-2.0>=2.7.8
${EXTRA_CLIENT_PKG_CONFIG}
)
......@@ -520,6 +541,7 @@ add_definitions(${CFLAGS})
set(VALAC_OPTIONS
--vapidir=${CMAKE_SOURCE_DIR}/bindings/vapi
--metadatadir=${CMAKE_SOURCE_DIR}/bindings/metadata
--metadatadir=${CMAKE_SOURCE_DIR}/bindings/metadata/${WEBKITGTK_METADATA_DIR}
--target-glib=${TARGET_GLIB}
--thread
--enable-checking
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment