Commit 1207a70d authored by Johannes Schmid's avatar Johannes Schmid Committed by Johannes Schmid

Fixed --disable-gnome Always use automake-1.9

2006-07-28  Johannes Schmid <jhs@gnome.org>

        * configure.in: Fixed --disable-gnome
        * autogen.sh: Always use automake-1.9
parent 70b3ad5d
2006-07-28 Johannes Schmid <jhs@gnome.org>
* configure.in: Fixed --disable-gnome
* autogen.sh: Always use automake-1.9
2006-07-19 Fredrik Axelsson <fraxbe@gmail.com>
reviewed by: Johannes Schmid <jhs@cvs.gnome.org>
......
#!/bin/sh
# Run this to generate all the initial makefiles, etc.
AUTOMAKE=automake-1.9
srcdir=`dirname $0`
test -z "$srcdir" && srcdir=.
......@@ -67,9 +69,9 @@ fi
}
}
(automake --version) < /dev/null > /dev/null 2>&1 || {
($AUTOMAKE --version) < /dev/null > /dev/null 2>&1 || {
echo
echo "**Error**: You must have \`automake' installed."
echo "**Error**: You must have $AUTOMAKE installed."
echo "You can get it from: ftp://ftp.gnu.org/pub/gnu/"
DIE=1
NO_AUTOMAKE=yes
......@@ -136,7 +138,7 @@ do
autoheader
fi
echo "Running automake --gnu $am_opt ..."
automake --add-missing --gnu $am_opt
$AUTOMAKE --add-missing --gnu $am_opt
echo "Running autoconf ..."
autoconf
)
......
......@@ -73,16 +73,10 @@ AC_SUBST(XML_LIBS)
PKG_CHECK_MODULES(GDL_DEPENDENCIES,
gtk+-2.0 >= $GTK_REQUIRED
libgnomeui-2.0 >= $GNOME_REQUIRED
libbonoboui-2.0 >= $BONOBOUI_REQUIRED
libglade-2.0 >= $LIBGLADE_REQUIRED)
AC_SUBST(GDL_DEPENDENCIES_CFLAGS)
AC_SUBST(GDL_DEPENDENCIES_LIBS)
PKG_CHECK_MODULES(XML, libxml-2.0 >= $XML_REQUIRED)
AC_SUBST(XML_CFLAGS)
AC_SUBST(XML_LIBS)
dnl ****************
dnl GNOME Libraries
dnl ****************
......@@ -110,7 +104,6 @@ else
[gnome="no"])
AC_SUBST(GNOME_CFLAGS)
AC_SUBST(GNOME_LIBS)
AC_MSG_RESULT([$gnome])
fi
AM_CONDITIONAL(HAVE_GNOME, [test x$gnome = xyes])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment