Commit d73be6ca authored by Bastien Nocera's avatar Bastien Nocera Committed by Emmanuele Bassi

Add missing 2.40 versioning macros

For the new API to be added.
parent a991b360
......@@ -248,6 +248,16 @@
*/
#define GDK_PIXBUF_VERSION_2_38 (G_ENCODE_VERSION (2, 38))
/**
* GDK_PIXBUF_VERSION_2_40:
*
* A macro that evaluates to the 2.40 version of GdkPixbuf,
* in a format that can be used by the C pre-processor.
*
* Since: 2.40
*/
#define GDK_PIXBUF_VERSION_2_40 (G_ENCODE_VERSION (2, 40))
#ifndef __GTK_DOC_IGNORE__
#if (GDK_PIXBUF_MINOR % 2)
#define GDK_PIXBUF_VERSION_CUR_STABLE (G_ENCODE_VERSION (GDK_PIXBUF_MAJOR, GDK_PIXBUF_MINOR + 1))
......@@ -687,4 +697,22 @@
#endif
#endif /* __GTK_DOC_IGNORE__ */
#ifndef __GTK_DOC_IGNORE__
#if GDK_PIXBUF_VERSION_MIN_REQUIRED >= GDK_PIXBUF_VERSION_2_40
#define GDK_PIXBUF_DEPRECATED_IN_2_40 G_DEPRECATED _GDK_PIXBUF_EXTERN
#define GDK_PIXBUF_DEPRECATED_IN_2_40_FOR(f) G_DEPRECATED_FOR(f) _GDK_PIXBUF_EXTERN
#else
#define GDK_PIXBUF_DEPRECATED_IN_2_40 _GDK_PIXBUF_EXTERN
#define GDK_PIXBUF_DEPRECATED_IN_2_40_FOR(f) _GDK_PIXBUF_EXTERN
#endif
#endif /* __GTK_DOC_IGNORE__ */
#ifndef __GTK_DOC_IGNORE__
#if GDK_PIXBUF_VERSION_MAX_ALLOWED < GDK_PIXBUF_VERSION_2_40
#define GDK_PIXBUF_AVAILABLE_IN_2_40 G_UNAVAILABLE(2, 40) _GDK_PIXBUF_EXTERN
#else
#define GDK_PIXBUF_AVAILABLE_IN_2_40 _GDK_PIXBUF_EXTERN
#endif
#endif /* __GTK_DOC_IGNORE__ */
#endif /* GDK_PIXBUF_MACROS_H */
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment