Commit 28b8f4d1 authored by Niels De Graef's avatar Niels De Graef

Release version 0.12.0

parent 0bbe705a
Pipeline #77306 passed with stage
in 7 minutes and 11 seconds
Overview of changes from libfolks 0.11.4 to libfolks 0.11.5
Overview of changes from libfolks 0.11.4 to libfolks 0.12.0
===========================================================
Dependencies:
* Dropped depedency on libvaladoc (we now use the binary directly)
* Bumped minimal GLib version to 2.44
Major changes:
* Folks is now being built using meson
* The autotools build definition was dropped
* Dropped support for building without vala
* Migrated to the GNOME GitLab and now use a CI-backed workflow
* Moved from intltool to gettext
* Various fixes for warnings
* Lots of translation updates
Bugs fixed:
* Bug 784544 - Fatal error building git master
* Bug 739997 - Crash when selecting contact
* Bug 792238 - PotentialMatch: don't rely on null-terminated string
* Bug 792567 - Individual.display_name: don't fallback on persona's display_id if it equals the IID
API changes:
......
project('folks', [ 'vala', 'c' ],
version: '0.11.5.0',
version: '0.12.0',
license: 'LGPL2.1+',
meson_version: '>= 0.49',
)
......@@ -21,18 +21,18 @@ folks_api_version = '0.6'
# number: a given libfolks.so will only load modules which were compiled
# against a core with the same major version as itself. This allows the API
# which is exposed to the modules to be changed.
folks_lib_version = '25.18.4'
folks_lib_version = '25.19.0'
# Each of the backend libraries (e.g. libfolks-eds.so; *not* the loadable
# modules, eds.so) has its own version. These should be incremented when the
# core folks_lib_version is incremented (as all the backend libraries are
# binary-dependent on libfolks.so), but should also be incremented when
# incompatible changes are made in the backend library APIs themselves.
folks_eds_lib_version = '25.18.4'
folks_libsocialweb_lib_version = '25.18.4'
folks_telepathy_lib_version = '25.18.4'
folks_tracker_lib_version = '25.18.4'
folks_dummy_lib_version = '25.18.4'
folks_eds_lib_version = '25.19.0'
folks_libsocialweb_lib_version = '25.19.0'
folks_telepathy_lib_version = '25.19.0'
folks_tracker_lib_version = '25.19.0'
folks_dummy_lib_version = '25.19.0'
# The module version is used to set the shared object versions
_version_split = folks_lib_version.split('.')
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment