Commit 5b5360bf authored by Jeremy Whiting's avatar Jeremy Whiting
Browse files

Change libgee dependency from 0.6 to 0.8.

parent 42bbfe49
......@@ -23,7 +23,7 @@ eds_deps = \
folks \
folks-internal \
folks-eds \
gee-1.0 \
gee-0.8 \
gio-2.0 \
gobject-2.0 \
libebook-1.2 \
......
......@@ -47,7 +47,7 @@ libfolks_eds_la_VALAFLAGS = \
--vapidir=$(top_srcdir)/folks \
--pkg folks \
--pkg folks-internal \
--pkg gee-1.0 \
--pkg gee-0.8 \
--pkg gio-2.0 \
--pkg gobject-2.0 \
--pkg libebook-1.2 \
......
......@@ -7,6 +7,6 @@ vapidir=@abs_top_srcdir@/folks
Name: Folks e-d-s support library (uninstalled copy)
Description: Evolution Data Server support library for the Folks meta-contacts library
Version: @VERSION@
Requires: folks glib-2.0 gobject-2.0 gee-1.0 libebook-1.2 libedataserver-1.2
Requires: folks glib-2.0 gobject-2.0 gee-0.8 libebook-1.2 libedataserver-1.2
Libs: ${abs_top_builddir}/backends/telepathy/libfolks-eds.la
Cflags: -I${abs_top_srcdir} -I${abs_top_srcdir}/backends/eds -I${abs_top_builddir}
......@@ -3,4 +3,4 @@ gobject-2.0
folks
libebook-1.2
libedataserver-1.2
gee-1.0
gee-0.8
......@@ -10,6 +10,6 @@ vapidir=@datadir@/vala/vapi
Name: Folks e-d-s support library
Description: Evolution Data Server support library for the Folks meta-contacts library
Version: @VERSION@
Requires: folks glib-2.0 gobject-2.0 gee-1.0 libebook-1.2 libedataserver-1.2
Requires: folks glib-2.0 gobject-2.0 gee-0.8 libebook-1.2 libedataserver-1.2
Libs: -L${libdir} -lfolks-eds
Cflags: -I${includedir}
......@@ -17,7 +17,7 @@ key_file_la_VALAFLAGS = \
--vapidir=$(top_srcdir)/folks \
--pkg folks \
--pkg folks-internal \
--pkg gee-1.0 \
--pkg gee-0.8 \
--pkg gio-2.0 \
--pkg gobject-2.0 \
$(NULL)
......
......@@ -23,7 +23,7 @@ libsocialweb_deps = \
folks \
folks-internal \
folks-libsocialweb \
gee-1.0 \
gee-0.8 \
gio-2.0 \
gobject-2.0 \
libsocialweb-client \
......
......@@ -43,7 +43,7 @@ libfolks_libsocialweb_la_VALAFLAGS = \
--pkg folks-internal \
--pkg gobject-2.0 \
--pkg gio-2.0 \
--pkg gee-1.0 \
--pkg gee-0.8 \
--pkg libsocialweb-client \
--includedir folks \
--vapi folks-libsocialweb.vapi \
......@@ -52,7 +52,7 @@ libfolks_libsocialweb_la_VALAFLAGS = \
folks_backend_libsocialweb_deps = \
folks \
gee-1.0 \
gee-0.8 \
gio-2.0 \
gobject-2.0 \
libsocialweb-client \
......
......@@ -7,6 +7,6 @@ vapidir=@abs_top_srcdir@/folks
Name: Folks Libsocialweb support library (uninstalled copy)
Description: Libsocialweb support library for the Folks meta-contacts library
Version: @VERSION@
Requires: folks glib-2.0 gobject-2.0 gee-1.0 libsocialweb-client
Requires: folks glib-2.0 gobject-2.0 gee-0.8 libsocialweb-client
Libs: ${abs_top_builddir}/backends/telepathy/libfolks-libsocialweb.la
Cflags: -I${abs_top_srcdir} -I${abs_top_srcdir}/backends/libsocialweb -I${abs_top_builddir}
......@@ -10,6 +10,6 @@ vapidir=@datadir@/vala/vapi
Name: Folks libsocialweb support library
Description: Libsocialweb support library for the Folks meta-contacts library
Version: @VERSION@
Requires: folks glib-2.0 gobject-2.0 gee-1.0 libsocialweb-client
Requires: folks glib-2.0 gobject-2.0 gee-0.8 libsocialweb-client
Libs: -L${libdir} -lfolks-libsocialweb
Cflags: -I${includedir}
......@@ -23,7 +23,7 @@ telepathy_deps = \
folks \
folks-internal \
folks-telepathy \
gee-1.0 \
gee-0.8 \
gio-2.0 \
gobject-2.0 \
telepathy-glib \
......
......@@ -120,7 +120,7 @@ libfolks_telepathy_la_VALAFLAGS = \
--pkg tp-lowlevel \
--pkg gobject-2.0 \
--pkg gio-2.0 \
--pkg gee-1.0 \
--pkg gee-0.8 \
--pkg telepathy-glib \
--pkg zeitgeist-1.0 \
--includedir folks \
......
......@@ -7,6 +7,6 @@ vapidir=@abs_top_srcdir@/folks
Name: Folks Telepathy support library (uninstalled copy)
Description: Telepathy support library for the Folks meta-contacts library
Version: @VERSION@
Requires: folks glib-2.0 gobject-2.0 gee-1.0 telepathy-glib >= 0.11.11
Requires: folks glib-2.0 gobject-2.0 gee-0.8 telepathy-glib >= 0.11.11
Libs: ${abs_top_builddir}/backends/telepathy/libfolks-telepathy.la
Cflags: -I${abs_top_srcdir} -I${abs_top_srcdir}/backends/telepathy -I${abs_top_builddir}
......@@ -10,6 +10,6 @@ vapidir=@datadir@/vala/vapi
Name: Folks Telepathy support library
Description: Telepathy support library for the Folks meta-contacts library
Version: @VERSION@
Requires: folks glib-2.0 gobject-2.0 gee-1.0 telepathy-glib >= 0.11.11
Requires: folks glib-2.0 gobject-2.0 gee-0.8 telepathy-glib >= 0.11.11
Libs: -L${libdir} -lfolks-telepathy
Cflags: -I${includedir}
......@@ -24,7 +24,7 @@ tracker_deps = \
folks \
folks-internal \
folks-tracker \
gee-1.0 \
gee-0.8 \
gio-2.0 \
gobject-2.0 \
tracker-sparql-$(TRACKER_SPARQL_MAJOR) \
......
......@@ -28,7 +28,7 @@ libfolks_tracker_la_VALAFLAGS = \
--pkg folks-internal \
--pkg gobject-2.0 \
--pkg gio-2.0 \
--pkg gee-1.0 \
--pkg gee-0.8 \
--pkg tracker-sparql-$(TRACKER_SPARQL_MAJOR) \
--includedir folks \
--vapi folks-tracker.vapi \
......@@ -37,7 +37,7 @@ libfolks_tracker_la_VALAFLAGS = \
folks_backend_tracker_deps = \
folks \
gee-1.0 \
gee-0.8 \
gio-2.0 \
gobject-2.0 \
tracker-sparql-$(TRACKER_SPARQL_MAJOR) \
......
......@@ -7,6 +7,6 @@ vapidir=@abs_top_srcdir@/folks
Name: Folks Tracker support library (uninstalled copy)
Description: Tracker support library for the Folks meta-contacts library
Version: @VERSION@
Requires: folks glib-2.0 gobject-2.0 gee-1.0 tracker-sparql-@TRACKER_SPARQL_MAJOR@
Requires: folks glib-2.0 gobject-2.0 gee-0.8 tracker-sparql-@TRACKER_SPARQL_MAJOR@
Libs: ${abs_top_builddir}/backends/telepathy/libfolks-tracker.la
Cflags: -I${abs_top_srcdir} -I${abs_top_srcdir}/backends/tracker -I${abs_top_builddir}
......@@ -10,6 +10,6 @@ vapidir=@datadir@/vala/vapi
Name: Folks tracker support library
Description: Tracker support library for the Folks meta-contacts library
Version: @VERSION@
Requires: folks glib-2.0 gobject-2.0 gee-1.0 tracker-sparql-@TRACKER_SPARQL_MAJOR@
Requires: folks glib-2.0 gobject-2.0 gee-0.8 tracker-sparql-@TRACKER_SPARQL_MAJOR@
Libs: -L${libdir} -lfolks-tracker
Cflags: -I${includedir}
......@@ -119,7 +119,7 @@ if test "x$enable_libsocialweb_backend" != "xno"; then
"x$enable_vala" = "xyes"; then
VALA_CHECK_PACKAGES([telepathy-glib
gio-2.0
gee-1.0
gee-0.8
libsocialweb-client],
,
have_libsocialweb_backend="no")
......@@ -163,18 +163,7 @@ PKG_CHECK_MODULES([GMODULE], [gmodule-no-export-2.0])
PKG_CHECK_MODULES([GIO], [gio-2.0 >= $GLIB_REQUIRED])
PKG_CHECK_MODULES([DBUS_GLIB], [dbus-glib-1])
# FIXME: We depend on libgee < 0.7 because 0.7 breaks API. bgo#627746
PKG_CHECK_MODULES([GEE], [gee-1.0 < 0.7],
have_gee_0_6_x="yes",
have_gee_0_6_x="no")
if test "x$have_gee_0_6_x" != "xyes"; then
AC_MSG_ERROR([
Gee 0.6.x required but not installed.
Note that Gee 0.8.x provides gee-0.8 (but gee-1.0 is, confusingly, provided by
Gee 0.6.x)])
fi
PKG_CHECK_MODULES([GEE], [gee-0.8])
TP_GLIB_REQUIRED=0.19.0
PKG_CHECK_MODULES([TP_GLIB], [telepathy-glib >= $TP_GLIB_REQUIRED])
......@@ -270,7 +259,7 @@ if test "x$enable_vala" = "xyes" ; then
VALA_CHECK_PACKAGES([telepathy-glib
gio-2.0
gee-1.0
gee-0.8
zeitgeist-1.0])
if test x$enable_tracker_backend = xyes; then
......
......@@ -79,7 +79,7 @@ folks_doc_files = \
folks_doc_deps = \
gmodule-2.0 \
gio-2.0 \
gee-1.0 \
gee-0.8 \
folks-internal \
build-conf \
$(NULL)
......@@ -111,7 +111,7 @@ folks_telepathy_doc_files = $(top_srcdir)/backends/telepathy/lib/*.vala
folks_telepathy_doc_deps = \
gmodule-2.0 \
gio-2.0 \
gee-1.0 \
gee-0.8 \
telepathy-glib \
zeitgeist-1.0 \
tp-lowlevel \
......@@ -173,7 +173,7 @@ folks_eds_doc_files = $(top_srcdir)/backends/eds/lib/*.vala
folks_eds_doc_deps = \
gmodule-2.0 \
gio-2.0 \
gee-1.0 \
gee-0.8 \
libebook-1.2 \
libedataserver-1.2 \
build-conf \
......@@ -242,7 +242,7 @@ folks_libsocialweb_doc_files = $(top_srcdir)/backends/libsocialweb/lib/*.vala
folks_libsocialweb_doc_deps = \
gmodule-2.0 \
gio-2.0 \
gee-1.0 \
gee-0.8 \
libsocialweb-client \
build-conf \
folks \
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment