Commit 3e8ea509 authored by Germán Poo-Caamaño's avatar Germán Poo-Caamaño

build: Disable PostScript backend by default

Evince depends on libspectre to render PostScript file, which
relies on Ghostscript. Ghostscript 9.23 and previous versions
have a security issue that allow run arbitrary commands in a
crafted PostScript file, even when it is called with the option
-dSAFER.

See issue #967
parent e82a13ac
......@@ -573,7 +573,7 @@ AC_ARG_ENABLE(ps,
[AS_HELP_STRING([--disable-ps],
[Disable the PostScript backend])],
[enable_ps=$enableval],
[enable_ps=yes])
[enable_ps=no])
if test "x$enable_ps" = "xyes"; then
if test "x$have_spectre" = "xyes"; then
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment