Verified Commit 2dbbb055 authored by Zander's avatar Zander 💥

Enforce supported lib versions

Except all those places where we override that...
parent ddc1c707
......@@ -68,6 +68,15 @@ configuration_inc = include_directories('.')
config_h_in = configure_file(output: 'config.h.in', configuration: conf)
config_h = vcs_tag(input: config_h_in, output: 'config.h')
gtk_ver = 'GDK_VERSION_2_24'
glib_ver = 'GLIB_VERSION_2_50'
add_project_arguments([
'-DGDK_VERSION_MIN_REQUIRED=@0@'.format(gtk_ver),
'-DGDK_VERSION_MAX_ALLOWED=@0@'.format(gtk_ver),
'-DGLIB_VERSION_MIN_REQUIRED=@0@'.format(glib_ver),
'-DGLIB_VERSION_MAX_ALLOWED=@0@'.format(glib_ver),
], language: 'c')
subdir('po')
subdir('lib')
subdir('objects')
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment