Commit 59affd80 authored by Emmanuele Bassi's avatar Emmanuele Bassi

Release Clutter 1.9.14 (snapshot)

parent a8d80058
Clutter 1.9.14 2012-03-05
===============================================================================
• List of changes since Clutter 1.9.12
- Support custom versioning boundaries for the API
Now that GLib provides macros for changing the minimum required and
maximum allowed version of a library, Clutter can respect the
boundaries expressed using CLUTTER_VERSION_MIN_REQUIRED and
CLUTTER_VERSION_MAX_ALLOWED.
- Add version information to deprecations
- Move all deprecated symbols to separate header files
- Documentation and annotation fixes.
- Accessibility fixes in Cally
Do not use ClutterActor:name as the accessible name, and do not
provide the extents of an accessible object if the actor to which
it refers is not on screen.
- Updates to the Wayland compositor and client support
Clutter now allows being used for creating hybrid Wayland/X11
compositors, working with KMS and evdev directly.
- Translation updates: Bulgarian, Ukranian, Galician, Uyghur, Belarusian,
Brazilian Portuguese, Telugu, Slovenian, Assamese, Serbian.
• List of bug fixes since Clutter 1.9.12
[bugzilla.gnome.org]
#670680 - "make check" assumes gdk backend will be built
Many thanks to:
Robert Bragg, Neil Roberts, Alejandro Piñeiro, Chun-wei Fan,
Alexander Shopov, Daniel Korostil, Daniel Mustieles, Fran Diéguez,
Gheyret Kenji, Giovanni Campagna, Ihar Hrachyshka, Jonh Wendell,
Krishnababu Krothapalli, Matej Urbančič, Nilamdyuti Goswami,
Мирослав Николић
Clutter 1.9.12 2012-02-23
===============================================================================
......
......@@ -10,7 +10,7 @@
# - increase clutter_interface_version to the next odd number
m4_define([clutter_major_version], [1])
m4_define([clutter_minor_version], [9])
m4_define([clutter_micro_version], [13])
m4_define([clutter_micro_version], [14])
# • for stable releases: increase the interface age by 1 for each release;
# if the API changes, set to 0. interface_age and binary_age are used to
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment