Commit edc47e17 authored by Luis Medinas's avatar Luis Medinas

Update configure to match GTK+ 3.0.0 GLIB 2.18 and Nautilus 3.0

Update dependencies to stable releases
parent a3408cdd
dnl Process this file with autoconf to produce a configure script.
AC_INIT([brasero],[2.91.7])
AC_INIT([brasero],[2.91.90])
AC_CONFIG_SRCDIR(src/main.c)
BRASERO_MAJOR_VERSION=2
BRASERO_MINOR_VERSION=91
BRASERO_SUB=7
BRASERO_SUB=90
BRASERO_VERSION=$BRASERO_MAJOR_VERSION.$BRASERO_MINOR_VERSION.$BRASERO_SUB
AC_SUBST(BRASERO_MAJOR_VERSION)
......@@ -138,12 +138,12 @@ dnl ***************** LARGE FILE SUPPORT ***********************
AC_SYS_LARGEFILE
dnl ********** Required libraries **********************
GLIB_REQUIRED=2.27.5
GLIB_REQUIRED=2.28.0
GTHREAD_REQUIRED=2.6.0
GMODULE_REQUIRED=2.6.0
GMODULE_EXPORT_REQUIRED=2.6.0
GIO_REQUIRED=2.27.1
GCONF_REQUIRED=2.31.1
GIO_REQUIRED=2.28.0
GCONF_REQUIRED=2.32.0
GSTREAMER_REQUIRED=0.10.15
GSTREAMER_BASE_REQUIRED=0.10.0
LIBXML2_REQUIRED=2.6.0
......@@ -217,7 +217,7 @@ AC_SUBST(BRASERO_SM_LIBS)
# GTK+ stuff (taken and adapted from empathy)
#
GTK_REQUIRED=2.91.7
GTK_REQUIRED=3.0.0
PKG_CHECK_MODULES([BRASERO_GTK], \
gtk+-3.0 >= $GTK_REQUIRED \
......@@ -250,8 +250,8 @@ AC_SUBST(BRASERO_CANBERRA_CFLAGS)
AC_SUBST(BRASERO_CANBERRA_LIBS)
dnl ****************Nautilus**********************************
# Note: the extension is built against gtk+-2.0 so we cannot build extension with gtk+-3.0
NAUTILUS_REQUIRED=2.22.2
# Note: the extension is built against gtk+-3.0 so we cannot build extension with gtk+-2.0
NAUTILUS_REQUIRED=2.91.90
AC_ARG_ENABLE(nautilus,
AS_HELP_STRING([--enable-nautilus],[Build Nautilus extension [[default=yes]]]),
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment