Commit 03fe8b6b authored by Andrew Walton's avatar Andrew Walton Committed by Philippe Rouquier

Remove trivial dependency on Eel.

2008-12-16  A. Walton  <awalton@gnome.org>

 	* configure.in:
	* nautilus/nautilus-burn-extension.c (launch_process):
	Remove trivial dependency on Eel.

svn path=/trunk/; revision=1647
parent 8c85b2aa
2008-12-16 A. Walton <awalton@gnome.org>
* configure.in:
* nautilus/nautilus-burn-extension.c (launch_process):
Remove trivial dependency on Eel.
2008-12-17 Philippe Rouquier <ykw@localhost.localdomain> 2008-12-17 Philippe Rouquier <ykw@localhost.localdomain>
Make sure the text of the tooltip for the tray icon is the same as Make sure the text of the tooltip for the tray icon is the same as
......
...@@ -203,7 +203,6 @@ fi ...@@ -203,7 +203,6 @@ fi
AM_CONDITIONAL(BUILD_GNOME2, test x"$build_gnome2" = "xyes") AM_CONDITIONAL(BUILD_GNOME2, test x"$build_gnome2" = "xyes")
dnl ****************Nautilus********************************** dnl ****************Nautilus**********************************
EEL_REQUIRED=2.13.3
NAUTILUS_REQUIRED=2.22.2 NAUTILUS_REQUIRED=2.22.2
AC_ARG_ENABLE(nautilus, AC_ARG_ENABLE(nautilus,
...@@ -212,8 +211,7 @@ AC_ARG_ENABLE(nautilus, ...@@ -212,8 +211,7 @@ AC_ARG_ENABLE(nautilus,
if test x"$enable_nautilus" = "xyes"; then if test x"$enable_nautilus" = "xyes"; then
PKG_CHECK_MODULES(NAUTILUS_EXTENSION, PKG_CHECK_MODULES(NAUTILUS_EXTENSION,
libnautilus-extension >= $NAUTILUS_REQUIRED \ libnautilus-extension >= $NAUTILUS_REQUIRED,
eel-2.0 >= $EEL_REQUIRED,
build_nautilus=yes, build_nautilus=yes,
build_nautilus=no) build_nautilus=no)
else else
......
...@@ -29,9 +29,6 @@ ...@@ -29,9 +29,6 @@
#include <glib/gi18n-lib.h> #include <glib/gi18n-lib.h>
#include <gtk/gtk.h> #include <gtk/gtk.h>
#include <libhal.h> #include <libhal.h>
#include <eel/eel-features.h>
#include <eel/eel-stock-dialogs.h>
#include <eel/eel-vfs-extensions.h>
#include <libnautilus-extension/nautilus-menu-provider.h> #include <libnautilus-extension/nautilus-menu-provider.h>
#include <libnautilus-extension/nautilus-location-widget-provider.h> #include <libnautilus-extension/nautilus-location-widget-provider.h>
...@@ -74,14 +71,6 @@ static void nautilus_burn_register_type (GTypeModule *module); ...@@ -74,14 +71,6 @@ static void nautilus_burn_register_type (GTypeModule *module);
static GObjectClass *parent_class; static GObjectClass *parent_class;
#ifndef EEL_CHECK_VERSION
#define EEL_CHECK_VERSION(major,minor,micro) \
(EEL_MAJOR_VERSION > (major) || \
(EEL_MAJOR_VERSION == (major) && EEL_MINOR_VERSION > (minor)) || \
(EEL_MAJOR_VERSION == (major) && EEL_MINOR_VERSION == (minor) && \
EEL_MICRO_VERSION >= (micro)))
#endif
#undef DEBUG_ENABLE #undef DEBUG_ENABLE
#ifdef DEBUG_ENABLE #ifdef DEBUG_ENABLE
...@@ -128,6 +117,7 @@ debug_print (const char *format, ...) ...@@ -128,6 +117,7 @@ debug_print (const char *format, ...)
static void static void
launch_process (char **argv, GtkWindow *parent) launch_process (char **argv, GtkWindow *parent)
{ {
GtkWidget *dialog;
GError *error; GError *error;
error = NULL; error = NULL;
...@@ -138,16 +128,14 @@ launch_process (char **argv, GtkWindow *parent) ...@@ -138,16 +128,14 @@ launch_process (char **argv, GtkWindow *parent)
NULL, NULL,
&error)) { &error)) {
#if EEL_CHECK_VERSION (2,13,3) dialog = gtk_message_dialog (NULL, GTK_DIALOG_MODAL, GTK_MESSAGE_WARNING,
eel_show_error_dialog (_("Unable to launch the cd burner application"), GTK_BUTTONS_OK, _("Unable to launch the cd burner application"));
error->message,
GTK_WINDOW (parent)); gtk_message_dialog_format_secondary_text (dialog, "%s", error->message);
#else
eel_show_error_dialog (_("Unable to launch the cd burner application"), gtk_dialog_run (dialog);
error->message, gtk_widget_destroy (dialog);
"",
GTK_WINDOW (parent));
#endif
g_error_free (error); g_error_free (error);
} }
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment