Commit 5392af56 authored by Christian Persch's avatar Christian Persch

sol: Fail to start when running with gtk+ 3.19 but compiled against earlier version

parent 3f79ea22
......@@ -144,6 +144,13 @@ cleanup:
int
main (int argc, char *argv[])
{
#if !GTK_CHECK_VERSION (3, 19, 5)
if (!gtk_check_version(3, 19, 5)) {
g_printerr("Aisleriot needs to be recompiled against gtk+ >= 3.19.5 in order to run with gtk+ >= 3.19.5\n");
return 1;
}
#endif
if (!ar_runtime_init ("aisleriot"))
return 1;
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment