Commit 66bc8760 authored by Alexander Larsson's avatar Alexander Larsson
Browse files

Add gnome-sdk target

parent 46561984
......@@ -10,3 +10,4 @@ packages/BUILD/
packages/RPMS/
packages/SRPMS/
packages/rpmdb/
gnome-sdk.tar.xz
......@@ -30,6 +30,8 @@ PACKAGES = \
dbus cairo dbus-glib \
graphite2 harfbuzz libdatrie libthai pango atk at-spi2-core at-spi2-atk gdk-pixbuf2 gtk3 \
itstool yelp-xsl yelp-tools \
hicolor-icon-theme libcroco vala librsvg2 adwaita-icon-theme \
gnome-sdk \
$(NULL)
SPECS =$(PACKAGES:%=packages/SPECS/%.spec)
......@@ -40,4 +42,11 @@ rpm-dependencies.P: $(SPECS) makedeps.sh yocto-build/x86_64/images/gnomeos-conte
./setup.sh root-sdk var-sdk yocto-build/x86_64/images/gnomeos-contents-sdk-x86_64.tar.gz
./build.sh root-sdk var-sdk packages ./makedeps.sh $(SPECS) > rpm-dependencies.P
gnome-sdk-rpmdb.tar.xz gnome-sdk.tar.xz: packages/RPMS/noarch/gnome-sdk-0.1-1.noarch.rpm
./setup.sh root-sdk var-sdk yocto-build/x86_64/images/gnomeos-contents-sdk-x86_64.tar.gz
./build.sh root-sdk var-sdk packages smart install -y packages/RPMS/noarch/gnome-sdk-0.1-1.noarch.rpm
rm -rf gnome-sdk.tar.xz
tar --transform 's,^root-sdk/usr/,,S' -cJvf gnome-sdk.tar.xz root-sdk/usr --owner=root
tar --transform 's,^var-sdk/,,S' -cJvf gnome-sdk-rpmdb.tar.xz var-sdk/lib/rpm --owner=root
-include rpm-dependencies.P
Name: gnome-sdk
Version: 0.1
Release: 1%{?dist}
Summary: Gnome sdk
License: Various
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
BuildArch: noarch
Requires: gtk3-devel
Requires: librsvg2-devel
Requires: hicolor-icon-theme
Requires: adwaita-icon-theme-devel
Requires: gtk-doc-stub
Requires: atk-devel
Requires: at-spi2-atk-devel
Requires: at-spi2-core-devel
Requires: cairo-devel
Requires: cairo-gobject-devel
Requires: dbus-devel
Requires: dbus-glib-devel
Requires: fontconfig-devel
Requires: freetype-devel
Requires: gdk-pixbuf2-devel
Requires: glib2-devel
Requires: gobject-introspection-devel
Requires: graphite2-devel
Requires: gtk3-devel
Requires: harfbuzz-devel
Requires: libcroco-devel
Requires: librsvg2-devel
Requires: libthai-devel
Requires: libX11-devel
Requires: libXau-devel
Requires: libxcb-devel
Requires: libXcomposite-devel
Requires: libXcursor-devel
Requires: libXdamage-devel
Requires: libXdmcp-devel
Requires: libXext-devel
Requires: libXfixes-devel
Requires: libXft-devel
Requires: libXi-devel
Requires: libXinerama-devel
Requires: libXrandr-devel
Requires: libXrender-devel
Requires: libXtst-devel
Requires: pango-devel
Requires: pixman-devel
Requires: vala-devel
%description
Meta package for Gnome SDK dependencies
%prep
%build
%install
%files
%doc
%changelog
* Fri Nov 7 2014 Alexander Larsson <alexl@redhat.com>
- Initial version
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment