Commit 3f182344 authored by Alexander Larsson's avatar Alexander Larsson
Browse files

Add clutter-gtk

parent 90b98e63
......@@ -43,7 +43,7 @@ PACKAGES = \
gnome-sdk gnome-platform dejavu-fonts abattis-cantarell-fonts \
gtk2 gnome-themes-standard libproxy gsettings-desktop-schemas glib-networking libsoup \
dconf gvfs desktop-file-utils json-glib libnotify vte mozjs24 gjs \
cogl clutter \
cogl clutter clutter-gtk \
zenity \
$(NULL)
......
%define clutter_version 1.0
Name: clutter-gtk
Version: 1.6.0
Release: 1%{?dist}
Summary: A basic GTK clutter widget
Group: Development/Languages
License: LGPLv2+
URL: http://www.clutter-project.org
Source0: http://download.gnome.org/sources/clutter-gtk/1.6/clutter-gtk-%{version}.tar.xz
BuildRequires: gnome-sdk-base
BuildRequires: gtk3-devel
BuildRequires: clutter-devel
BuildRequires: gobject-introspection-devel
%description
clutter-gtk is a library which allows the embedding of a Clutter
canvas (or "stage") into a GTK+ application, as well as embedding
GTK+ widgets inside the stage.
%package devel
Summary: Clutter-gtk development environment
Group: Development/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
Header files and libraries for building a extension library for the
clutter-gtk.
%prep
%setup -q
%build
%configure
make %{?_smp_mflags} V=1
%install
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p"
#Remove libtool archives.
find %{buildroot} -type f -name "*.la" -delete
%find_lang cluttergtk-1.0
%check
make check %{?_smp_mflags} V=1
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files -f cluttergtk-1.0.lang
%doc COPYING NEWS
%{_libdir}/*.so.*
%{_libdir}/girepository-1.0/GtkClutter-%{clutter_version}.typelib
%files devel
%{_includedir}/clutter-gtk-%{clutter_version}/
%{_libdir}/pkgconfig/clutter-gtk-%{clutter_version}.pc
%{_libdir}/*.so
%{_datadir}/gir-1.0/GtkClutter-%{clutter_version}.gir
%{_datadir}/gtk-doc/html/clutter-gtk-1.0
%changelog
* Thu Dec 11 2014 Alexander Larsson <alexl@redhat.com> - 1.6.0-1
- Initial version
......@@ -36,6 +36,7 @@ Requires: mesa-libEGL
Requires: mesa-dri-drivers
Requires: libepoxy
Requires: clutter
Requires: clutter-gtk
%description
Meta package for Gnome SDK dependencies
......
......@@ -32,7 +32,7 @@ BuildRequires: mesa-libGL
BuildRequires: libICE-devel
BuildRequires: libXxf86vm-devel
BuildRequires: libepoxy-devel
BuildRequires: clutter-devel
BuildRequires: clutter-gtk-devel
Requires: gtk2-devel gtk2-immodules
Requires: gtk3-devel gtk3-immodules
......@@ -99,6 +99,7 @@ Requires: libXxf86vm-devel
Requires: libepoxy-devel
Requires: cogl-devel
Requires: clutter-devel
Requires: clutter-gtk-devel
%description
Meta package for Gnome SDK dependencies
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment