Commit 614b81ff authored by Michael Natterer's avatar Michael Natterer 😴

app, tools: rename "gimpdebug" to "gimp-debug-tool"

and use GIMP_TOOL_VERSION instead of hardcoding "2.0" in both
tools/Makefile.am and app/errors.c
parent 110779eb
......@@ -103,6 +103,7 @@ AM_CPPFLAGS = \
-DGIMPDIR=\""$(gimpdir)"\" \
-DLIBEXECDIR=\""$(libexecdir)"\" \
-DGIMP_USER_VERSION=\"$(GIMP_USER_VERSION)\" \
-DGIMP_TOOL_VERSION=\"$(GIMP_TOOL_VERSION)\" \
-DG_LOG_DOMAIN=\"Gimp\" \
-DGIMP_APP_GLUE_COMPILATION \
-DCC_VERSION=\""$(CC_VERSION)"\" \
......
......@@ -298,11 +298,11 @@ gimp_eek (const gchar *reason,
* takes precedence over the command line argument.
*/
#ifdef G_OS_WIN32
const gchar *gimpdebug = "gimpdebug-2.0.exe";
const gchar *gimpdebug = "gimp-debug-tool-" GIMP_TOOL_VERSION ".exe";
#elif defined (PLATFORM_OSX)
const gchar *gimpdebug = "gimpdebug-2.0";
const gchar *gimpdebug = "gimp-debug-tool-" GIMP_TOOL_VERSION;
#else
const gchar *gimpdebug = LIBEXECDIR "/gimpdebug-2.0";
const gchar *gimpdebug = LIBEXECDIR "/gimp-debug-tool-" GIMP_TOOL_VERSION;
#endif
gchar *args[7] = { (gchar *) gimpdebug, full_prog_name, NULL,
(gchar *) reason, (gchar *) message,
......
......@@ -19,9 +19,10 @@
*/
/*
* This widget is particular that I want to be able to use it internally
* but also from an alternate tool (gimpdebug). It means that the
* implementation must stay as generic glib/GTK+ as possible.
* This widget is particular that I want to be able to use it
* internally but also from an alternate tool (gimp-debug-tool). It
* means that the implementation must stay as generic glib/GTK+ as
* possible.
*/
#include "config.h"
......@@ -200,11 +201,12 @@ gimp_critical_dialog_finalize (GObject *object)
/* XXX This is taken straight from plug-ins/common/web-browser.c
*
* This really sucks but this class also needs to be called by
* tools/gimpdebug.c as a separate process and therefore cannot make use
* of the PDB. Anyway shouldn't we just move this as a utils function?
* Why does such basic feature as opening a URL in a cross-platform way
* need to be a plug-in?
* tools/gimp-debug-tool.c as a separate process and therefore cannot
* make use of the PDB. Anyway shouldn't we just move this as a utils
* function? Why does such basic feature as opening a URL in a
* cross-platform way need to be a plug-in?
*/
static gboolean
browser_open_url (const gchar *url,
......
......@@ -610,6 +610,6 @@ app/xcf/xcf-save.c
app/xcf/xcf-seek.c
app/xcf/xcf-write.c
tools/gimpdebug.c
tools/gimp-debug-tool.c
data/tags/gimp-tags-default.xml.in
......@@ -5,6 +5,8 @@
/kernelgen
/gimptool-2.0
/gimptool-2.0.exe
/gimp-debug-tool-2.0
/gimp-debug-tool-2.0.exe
/test-clipboard
/test-clipboard.exe
/invert-svg
......
......@@ -7,20 +7,20 @@ libgimpbase = $(top_builddir)/libgimpbase/libgimpbase-$(GIMP_API_VERSION).la
if OS_WIN32
bin_PROGRAMS = \
gimptool-2.0 \
gimpdebug-2.0 \
gimptool-@GIMP_TOOL_VERSION@ \
gimp-debug-tool-@GIMP_TOOL_VERSION@ \
gimp-debug-resume
gimp_debug_resume_SOURCES = gimp-debug-resume.c
else
bin_PROGRAMS = gimptool-2.0
bin_PROGRAMS = gimptool-@GIMP_TOOL_VERSION@
if PLATFORM_OSX
bin_PROGRAMS += gimpdebug-2.0
bin_PROGRAMS += gimp-debug-tool-@GIMP_TOOL_VERSION@
else
libexec_PROGRAMS = gimpdebug-2.0
libexec_PROGRAMS = gimp-debug-tool-@GIMP_TOOL_VERSION@
endif
endif
......@@ -30,14 +30,14 @@ noinst_PROGRAMS = test-clipboard
EXTRA_PROGRAMS = \
kernelgen
gimpdebug_2_0_SOURCES = \
gimpdebug.c \
gimp_debug_tool_@GIMP_TOOL_VERSION@_SOURCES = \
gimp-debug-tool.c \
../app/widgets/gimpcriticaldialog.h \
../app/widgets/gimpcriticaldialog.c \
../app/gimp-version.h \
../app/gimp-version.c
gimpdebug_2_0_CPPFLAGS = \
gimp_debug_tool_@GIMP_TOOL_VERSION@_CPPFLAGS = \
-DCC_VERSION=\""$(CC_VERSION)"\" \
-I$(top_srcdir)/app \
-I$(top_builddir)/app \
......@@ -47,16 +47,16 @@ gimpdebug_2_0_CPPFLAGS = \
$(GTK_CFLAGS) \
$(FONTCONFIG_CFLAGS)
gimpdebug_2_0_LDADD = \
gimp_debug_tool_@GIMP_TOOL_VERSION@_LDADD = \
$(GIO_LIBS) \
$(GEGL_LIBS) \
$(GTK_LIBS) \
$(FONTCONFIG_LIBS)
gimptool_2_0_SOURCES = gimptool.c
gimptool_@GIMP_TOOL_VERSION@_SOURCES = gimptool.c
gimptool_2_0_LDADD = \
gimptool_@GIMP_TOOL_VERSION@_LDADD = \
$(libgimpbase) \
$(GTK_LIBS)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment